Please help! Rc car problem - RCCanada - Canada Radio Controlled Hobby Forum
RCCanada - Canada's Radio Control Hobby Forum
Electric RC Car and Truck Discussion Discuss electric RC vehicles

Thread Tools Display Modes
Old 04-08-2011, 10:59 PM   #1
RCC Noob
I am: Kyle A
Join Date: Apr 2011
Location: Canada, ontario
Radio of choice:
Acoms Technisport 2.4 ghz
# of RCs: 5

Feedback: 0 / 0%
Posts: 8
Total Props: 0
Angry Please help! Rc car problem

       Remove this ad - become a site supporter!
ok, so i like have a kyosho ultima rb5 and a brand new , just built tamiya transyberia rc truck. My kyosho runs but once it comes to a complete stop, the motor just quits and it stops running. the steering still works but the motor is silent. The most intresting part is that if you spin the motor, or the wheels, the motor jumps back to life and the ar runs again, but only until it comes to a complete stop. I have a
novak brushless system on it and a brand new lipo battery. i checked all my connections and my battery is charged. :confused

For my transyberia, the stering works but the engine does not. If I adjust the steering or throttle trim the engin moves the car on it's own. Ucmu throttle the car jumps an inch or so at slow speeds then freezes. If i gently press the trottle the car moves extremely slowly but dose not stop. If i attemp tye go faster the motor i said, this is a brand new 250 $ truck and i have no clue what could be causeing this. im not really new to the hobby but ii still have a lot to learn . I really appreciate any help. sorry fot the long entry but this is really troubling me. ( ps, everything is stock on the transyberia and the ultima is secondhand but in decent condition)


Last edited by RCbuggydriver; 04-08-2011 at 11:09 PM.
RCbuggydriver is offline   Quick reply to this message.

Sponsored Links - Subscribe to remove this ad.
Old 04-09-2011, 07:57 AM   #2
Level 3 Supporter
★ Site Supporter ★
Cougar429's Avatar
I am: Gary L
Join Date: Aug 2008
Location: Tecumseh, Ontario

Feedback: 72 / 100%
Posts: 5,249
Total Props: 30
Re: Please help! Rc car problem

Not familiar with trucks or cars, but when looking at one of their systems for my boat I believe you have to set the throttle end points in the motor controller. That sounds like it could be your problem.

What condition are the batteries? Charge state?
I know there's money in aviation........I put it there!
Cougar429 is offline   Quick reply to this message.

rc electic problem

Quick Reply

Register Now

In order to be able to post messages on the RCCanada - Canada Radio Controlled Hobby Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionally, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Your Name
Your first name and last initial is required if you plan on using the forum.
Which city & province you live in. This is mandatory for classified listings.
Radio of choice?
Which radio is your current favorite to use?
Number of RC Vehicles?
How many boats, cars, planes do you own?


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
vBulletin Message

Thread Tools
Display Modes

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is this a design problem or a launch problem? jpmodels General RC Aircraft Discussion 12 04-29-2009 10:00 PM
Charger problem! - PROBLEM SOLVED Thanks my friends. Gary Maker Electronics 4 03-21-2008 02:06 PM
Looking For a Cheap Nitro Car or Drag car moto6 WTB + Trade RC Car & Truck items 0 09-10-2007 02:27 PM
Is my Triton charger having a problem??? (PROBLEM FIXED!!!) Heli-Flyer Electronics 5 06-07-2004 10:38 AM
Wild Hare Edge Aileron Problem! NEW: Problem addressed!!!! Brian Facey Scale Aerobatics 7 04-18-2004 09:10 AM

All times are GMT -5. The time now is 05:18 PM.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.