Need help..... - Page 2 - RCCanada - Canada Radio Controlled Hobby Forum
RCCanada - Canada's Radio Control Hobby Forum
General RC Aircraft Discussion Discuss anything RC related

Thread Tools Display Modes
Old 04-19-2011, 05:48 PM   #11
RCC Apprentice
ctdang's Avatar
I am: Nick
Join Date: Jul 2010
Location: mississaga
Radio of choice:
# of RCs: 6

Feedback: 4 / 100%
Posts: 80
Total Props: 0
Re: Need help.....

       Remove this ad - become a site supporter!
Thank u Max for helping me figure out the problem, turns out the 1 of the servo's was broken.
ctdang is offline   Quick reply to this message.

Sponsored Links - Subscribe to remove this ad.
Old 04-20-2011, 08:03 AM   #12
★ Site Supporter ★★ Administrator ★
Max's Avatar
I am: Max P.
Join Date: Feb 2007
Location: Aurora, Ontario
Radio of choice:
JR and Spektrum

Feedback: 20 / 100%
Posts: 13,440
Total Props: 149
Re: Need help.....

Originally Posted by ctdang View Post
Thank u Max for helping me figure out the problem, turns out the 1 of the servo's was broken.
Your'e welcome!! It's always a pleasure to help a fellow RCC'er

For you guys that are curious, here is what happened:

Original Problem:
Originally Posted by ctdang View Post
Hey guys ok it's been 7 months since i last flown my t-rex 450 now when i tried to turn it on it's not working i tried to rebind it and still doesn't work, may there be something wrong with the reciever??? or can an expert that lives near the markham area give me a hand for a little cash... might have to trim out my heli too.
a few seconds after power-up, the RX would indicate loss of signal, over and over again.

We tried to rebind, and after several tries, I noticed the RX would bind, and then immediately go into rebind mode (a few seconds after binding, the RX LED would flash as if it wanted to bind again) To me this pointed out the fact that the power was being interrupted. It was just like the RX was being powered on, powered off then powered on again.

Further investigation revealed a stalled cyclic servo. I suspect the stalled servo was sucking the power out of the ESC to the point that it could not provide enough power to run the RX, hence the loss of bind. I cannot explain the reason the servo was stalled. It would work then it would not work... Then it would work again. Just defective, I guess.
RC Test Pilot; FPV Instructor, Airplane Instructor; Helicopter Instructor

My Aircraft Albums:

Last Photo added: Dec 15; Warwing Foamy for FPV
Max is offline   Quick reply to this message.

Quick Reply

Register Now

In order to be able to post messages on the RCCanada - Canada Radio Controlled Hobby Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionally, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Your Name
Your first name and last initial is required if you plan on using the forum.
Which city & province you live in. This is mandatory for classified listings.
Radio of choice?
Which radio is your current favorite to use?
Number of RC Vehicles?
How many boats, cars, planes do you own?


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
vBulletin Message

Thread Tools
Display Modes

Forum Jump

All times are GMT -5. The time now is 08:19 AM.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.