Ailerons stopped working - RCCanada - Canada Radio Controlled Hobby Forum
RCCanada - Canada's Radio Control Hobby Forum
General RC Aircraft Discussion Discuss anything RC related

Thread Tools Display Modes
Old 07-07-2011, 07:28 PM   #1
RCC Senior Contributor
I am: Jean Pierre
Join Date: Aug 2008
Location: Victoriaville, Qc. G6S 1K3
Radio of choice:
JR 7202
# of RCs: 12

Feedback: 12 / 100%
Posts: 567
Total Props: 3
Ailerons stopped working

       Remove this ad - become a site supporter!
Yesterday I was flying my little Twist and after 12minutes of my second flight the ailerons started acting bizar like when I was turning right it was hard to do and the plane was shaking so I managed to land it and while I was checking the ailerons working, they stopped moving completely. All other servos were working fine. After a few tryings and a few switch reset, everything cameback to normal. I tried to reproduce the problem but they seem to work perfectly.
This plane is set with 1 servo per aileron and are conected with a Y connector to a JR 7 chanels RX on chanel 55 and my radio is a 7202.
Could it be the receiver or the TX? When it happened the battery voltage was 5.0 wich is normal after two flights.
Thank for your help!
Flyinbullmax is offline   Quick reply to this message.

Sponsored Links - Subscribe to remove this ad.
Old 07-07-2011, 07:46 PM   #2
RCC Senior Contributor
I am: Don M
Join Date: Dec 2002
Location: Chatham, Ont

Feedback: 5 / 100%
Posts: 705
Total Props: 3
Re: Ailerons stopped working

Quite possibly the y connector had poor connection or oxidized terminals- maybe plugging it in and out a few times temporarily cured the problem, but I would replace it.
goneflyin is offline   Quick reply to this message.
Old 07-07-2011, 09:15 PM   #3
Level 3 Supporter
★ Site Supporter ★
Pauld's Avatar
I am: Paul D
Join Date: Apr 2005
Location: Coquitlam, B.C.
Radio of choice:
Fubar S-bus2 -no lock outs :)
# of RCs: 10+

Feedback: 9 / 100%
Posts: 2,520
Total Props: 21
Re: Ailerons stopped working

Do both servos go at the same time and act the same or just one at a time. If it's one then there could be a bad wiring connection, if its both then it must be upstream of the servos.

What I have experienced before was with 2 servos plugged into one channel and the signal voltage level on the "control" wire (white or orange). The amplifier in the receiver simply didnt have enough voltage to drive 2 servos and eventually would crap out. Both servos would then jump around like they were confused.

MAAC Jet Committee/JPO Western Canada
2L club executive member
Pauld is offline   Quick reply to this message.
Old 07-08-2011, 09:01 AM   #4
Tyler P
RCC Supreme Contributor
Tyler P's Avatar
I am: Tyler P
Join Date: Oct 2008
Location: Osgoode, ON
Radio of choice:
JR 9503
# of RCs: 10

Feedback: 0 / 0%
Posts: 2,394
Total Props: 6
Re: Ailerons stopped working

I just recently setup my ailerons on a Y in a single channel and I find that they don't have enough juice. I think I may have to go back to my original setup as they just don't feel effective enough and they definitely don't have the holding power they did before.

That being said, the servos are getting old and I do beat on that plane pretty hard. It might be time for a new set of servos.

I agree with the others that a connection may have been the culprit. I recently had something similar in my 100cc and it turned out to be a loose connector.
Team Great Hobbies
Team Durango Canada
Tyler P is offline   Quick reply to this message.

Quick Reply

Register Now

In order to be able to post messages on the RCCanada - Canada Radio Controlled Hobby Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionally, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Your Name
Your first name and last initial is required if you plan on using the forum.
Which city & province you live in. This is mandatory for classified listings.
Radio of choice?
Which radio is your current favorite to use?
Number of RC Vehicles?
How many boats, cars, planes do you own?


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
vBulletin Message

Thread Tools
Display Modes

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hitec servo stopped working? offroader General RC Car & Truck discussion 6 06-23-2009 05:56 PM
G2 USB interlink stopped working. PurgatorY Flight Simulators 3 02-20-2008 05:57 PM
F-15 Started and stopped shep1 Electric Jets 8 08-03-2006 08:15 PM
R.C.M. Magazine, Stopped Publishing? Strine General RC Aircraft Discussion 15 11-12-2005 10:02 PM
Ailerons Airnut Construction Ideas, Hints and Tips 3 07-06-2005 04:37 AM

All times are GMT -5. The time now is 02:17 AM.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.