Rcexcell opti-kill and tachometer - RCCanada - Canada Radio Controlled Hobby Forum
RCCanada - Canada's Radio Control Hobby Forum
Electronics Discuss radios, chargers, etc...

Thread Tools Display Modes
Old 10-06-2012, 03:27 PM   #1
RCC Noob
I am: Lorne W
Join Date: Nov 2010
Location: Fraser Lake, B.C.
Radio of choice:
Futaba 10CAG
# of RCs: 7

Feedback: 0 / 0%
Posts: 18
Total Props: 0
Rcexcell opti-kill and tachometer

       Remove this ad - become a site supporter!
Hi, Me again, really need some help here.......

Just upgraded from a 9Z radio to a futaba 10cag with a 6014HS receiver in my new aeroworks 300 60-90.

I have the DLE 20 in it along with an rcexcell tach and optikill switch. Right from day one the tach never worked right.... always rebooting to zeros ... all the time. I just eventually gave up on it and used the tach on the 9Z radio for tuning. Figured i had wasted a couple of bucks but oh well...When I swapped in the 6014HS receiver I put the optikill onto channel 10 and assigned that to a switch. The plane has always run ok but I have always had a problem with it at the midrange. Yesterday after flying I decided to do a little more tuning. Again, that tach was no help so I was using the old 9Z. At one point I noticed that when I shut off the Futaba 10 the optikill would not shut down. It seems there is no failsafe for chan. 9 and 10 on this radio. No big deal, I switched the optikill to chan 7 and assigned it to the same switch. Next thing you know I hear some crackling and can smell something frying. Turns out the output power wire on the optikill fried itself right off of its board. I never set the channel endpoints to max (I find out now on the forums that I should have done that) so I hope that is what caused it. Then I was worried that I had burned out the ignition so I plugged a fresh batt right into the ignition and it seems to run as good as it did before. So now I wait until monday to order another optikill from Valleyview.

I decided today to look into the tach issue... Here is what I found... Power on to ignition,everything hooked up.... I spin the prop slow and everytime the plug fires, the tach reboots. If I remove the spark plug wire from the plug, It will showa 3 or 4 depending on how fast I spin the prop. Remove the plug from the engine and put it into the plug wire and spin the prop all is well, no reboot. Then screw the plug back into the head and connect spark plug wire, the tach reboots when the plug fires. Could this be a ground issue that is not doing my midrange any good? The tach reads fine when the engine is running above 7000 rpm, any lower than that it eventually starts its reboot cycle, over and over.

I gotta order another optikill on monday and if I need an ignition I'd like to order it at the same time but I dont know what the problem is....

Any help anyone?

Thank, Broncoflyer
broncoflyer is offline   Quick reply to this message.

Sponsored Links - Subscribe to remove this ad.

Quick Reply

Register Now

In order to be able to post messages on the RCCanada - Canada Radio Controlled Hobby Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionally, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Your Name
Your first name and last initial is required if you plan on using the forum.
Which city & province you live in. This is mandatory for classified listings.
Radio of choice?
Which radio is your current favorite to use?
Number of RC Vehicles?
How many boats, cars, planes do you own?


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
vBulletin Message

Thread Tools
Display Modes

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Opti-kill stays live when Tx shut off grosbeak Electronics 5 06-25-2012 09:23 PM
opti kill setup question Rooky General RC Aircraft Discussion 13 10-30-2010 06:47 PM
Wanted Opti Kill RAMJET Wanted - Electronics 0 02-09-2009 05:56 PM
Need you help re: Revo's Opti-Drive BimBim General RC Car & Truck discussion 1 05-24-2008 09:23 AM
Need your help re: Revo's Opti-Drive BimBim Nitro RC Car and Truck Discussion 1 05-24-2008 12:50 AM

All times are GMT -5. The time now is 05:10 AM.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.