arggg traxxas - RCCanada - Canada Radio Controlled Hobby Forum
RCCanada - Canada's Radio Control Hobby Forum
Offroad RC Discussion RC Offroad chat for truggies, buggies, short-course and more. Topics may include brands like Associated, Kyosho, Tamiya, Axial, Traxxas and more.

Closed Thread
Thread Tools Display Modes
Old 04-13-2010, 10:35 PM   #1
RCC Junior Contributor
kennysteez's Avatar
I am: kenny s
Join Date: Apr 2010
Location: pickering Ontario

Feedback: 0 / 0%
Posts: 218
Total Props: 0
Angry arggg traxxas

       Remove this ad - become a site supporter!
so i just replaced my spur gear on my slash 4x4 and now everything seams to be off my breaks dont work as well when i stop ( or lack their of) im hearing a faint metal sliding sound almost as if my slipper clutch is spinning on the clutch plate but its not its tight i know every thing is done and instaled prober as i have worked at 2 hobby well knowen hobby shops and learned a lot but its starting to get real annoying also my truck dosent seem to have as much power any more and i cant figuer that out eathier any help would be much appricated

thx in advance

sorry for the wall of words
kennysteez is offline   Quick reply to this message.

Sponsored Links - Subscribe to remove this ad.
Old 04-14-2010, 02:33 AM   #2
ert's Avatar
Join Date: Apr 2007

Feedback: 0 / 0%
Posts: 232
Total Props: 0
I know you are saying the slipper is tight but everything you described sounds like your slipper is loose or slipping. Did you have you slipper set loose before ? The reason why i ask is that the disc and the pads can overheat, I had a brushless rustler with the same style slipper and it overheated. It was so bad that the pads went glossy and the disc went purple in some spots after that it wouldn't hold no matter how tight i went, I tried scuffing the pads and and the disc with some fine sand paper it worked for a while but then i ended up replacing them any way. Try holding the truck down all 4 tires on the pavment and give it a bit a throttle and see if the spur spins but not the drive shaft there is something wrong with the slipper, hope that helps.
ert is offline   Quick reply to this message.
Closed Thread

Quick Reply

Register Now

In order to be able to post messages on the RCCanada - Canada Radio Controlled Hobby Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionally, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Your Name
Your first name and last initial is required if you plan on using the forum.
Which city & province you live in. This is mandatory for classified listings.
Radio of choice?
Which radio is your current favorite to use?
Number of RC Vehicles?
How many boats, cars, planes do you own?


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
vBulletin Message

Thread Tools
Display Modes

Forum Jump

All times are GMT -5. The time now is 03:35 AM.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.