Nano CXP HELP - RCCanada - Canada Radio Controlled Hobby Forum
RCCanada - Canada's Radio Control Hobby Forum
Electric RC Helis Discuss helicopters, setups and power systems for electric helicopters.

Thread Tools Display Modes
Old 02-19-2013, 10:41 PM   #1
heli newbie
RCC Noob
I am: rodney biggar
Join Date: Feb 2013
Location: spruce grove ab
# of RCs: 7

Feedback: 0 / 0%
Posts: 16
Total Props: 0
Elec Nano CXP HELP

       Remove this ad - become a site supporter!
Hi Guys,

Having a small problem with my nano. I was flying it this weekend, and could not get my transmitter to bind. I gave up. I tried again tonight, and it worked. So I ran through 3 batteries, and on my 4th one, it kept 'cutting out' like it was loosing signal and the blue light would shut off. I put it down, and i would throttle up, and it would cut in and out. I unpluggled the battery, and plugged it back in, and now it wont bind again.

Wondering if you think it is a problem with my DX7, or with the FBL receiver in the the nano? Or something else, cause as my name says, I am a newb! LOL

Thanks in advance for any/all comments or advice!
heli newbie is offline   Quick reply to this message.

Sponsored Links - Subscribe to remove this ad.
Old 02-20-2013, 07:06 AM   #2
RCC Apprentice
Jamie_Fleming's Avatar
I am: Jamie F
Join Date: Feb 2012
Location: Woodstock Ontario
Radio of choice:
# of RCs: 20

Feedback: 0 / 0%
Posts: 32
Total Props: 1

with my dx7 if the rate switchs are in high rate went the battary is plug in the heli will loss it bind
Fly them until you broke them
Jamie_Fleming is offline   Quick reply to this message.
Old 02-23-2013, 12:31 PM   #3
RCC Apprentice
I am: Myles S
Join Date: Apr 2008
Location: Victoria BC Canada

Feedback: 0 / 0%
Posts: 74
Total Props: 0

Mine doesn't automatically bind sometimes, and a lot of people have had troubles. Seems to be some flaw in the board.

If you want, here's some reading for you.

When I plug it in and get the rapidly flashing light I just switch off my transmitter and fire it up with the bind switch on, and rebind it. I find it easier than unplugging the heli battery.

You might be able to talk your hobby shop into exchanging it for another one, or call Horizon and they'll probably ask you to send it in.
static80 is offline   Quick reply to this message.
Old 02-24-2013, 04:41 AM   #4
RCC Expert Contributor
I am: Jeremy
Join Date: Nov 2009
Location: Kentville, Nova Scotia
Radio of choice:
# of RCs: 10+

Feedback: 6 / 100%
Posts: 967
Total Props: 39

Most of the blade helis don't bind well if the batteries are at all low. They need to be in good condition and fully charged.
Tower is offline   Quick reply to this message.
Old 02-24-2013, 05:27 AM   #5
RCC Master Contributor
Rob's Avatar
I am: Rob
Join Date: Nov 2003
Location: Owen Sound

Feedback: 11 / 100%
Posts: 1,248
Total Props: 0

I had a friend who had the exact same problem. He found he made a new model in the TX and all was good. Try eraseing the model and start with a fresh one it fixed my friends
What do you mean , I can land upside down
Rob is offline   Quick reply to this message.
Old 02-24-2013, 11:18 PM   #6
I am: Boolean21
Join Date: Sep 2002
Location: Singapore

Feedback: 0 / 0%
Posts: 38,228
Total Props: 56

Reset your transmitter back to factory settings for the Nano. Disconnect all the servo links to the push rods so the servo's have no load on them.
Rebind it once more and see how the servo's behave. That should narrow it down to a binding swash plate or an electrical/servo problem. The chance of all three servos going bad is slim.
PurgatorY is offline   Quick reply to this message.
Old 02-26-2013, 10:50 AM   #7
RCC Apprentice
I am: andrew h
Join Date: Jan 2012
Location: toronto

Feedback: 6 / 100%
Posts: 41
Total Props: 0

It could also be lipo abuse, that your battery has discharged too low and this is a warning to charge it.
andrewho83 is offline   Quick reply to this message.
Old 02-26-2013, 10:21 PM   #8
heli newbie
RCC Noob
I am: rodney biggar
Join Date: Feb 2013
Location: spruce grove ab
# of RCs: 7

Feedback: 0 / 0%
Posts: 16
Total Props: 0

thanks for all the info guys. all my batteries are very new, and it did the same thing with different batteries, so I dont think it would be that. I called horizon, and they are said it could be the motor taking too much draw, they are sending me replacement motors under warranty. If that doesnt fix it, I will send it in to them and they can look at it further.
heli newbie is offline   Quick reply to this message.
Old 02-27-2013, 04:33 AM   #9
RCC Apprentice
I am: Peter M
Join Date: Aug 2007
Location: Thorold, Ontario, Canada
Radio of choice:

Feedback: 4 / 100%
Posts: 90
Total Props: 0

Mine is the same tho g when the motor was on its way out
Kandler Race Motors
VooDooMafia is offline   Quick reply to this message.
Old 02-28-2013, 11:58 PM   #10
RCC Apprentice
I am: Eggma
Join Date: Feb 2013
Location: Toronto, ON
Radio of choice:

Feedback: 2 / 100%
Posts: 35
Total Props: 0

I had this problem too 2 days after I bought it. In my case turned out to be the board. Horizon sent me a new one, arrived within a week. This is how I tested it. I hold the heli in your hand, and play with the throttle, and slightly move the battery wire to see if that's the problem. Also slightly move the antenna and see if that's the problem. If those 2 are not the problem you can also take out the main motor and connect it directly to the battery to see if the motor functions properly. In my case it was a lose battery wire soldering....
eggma is offline   Quick reply to this message.

binding , help!!! , nano , Nano cpx , problem

Quick Reply

Register Now

In order to be able to post messages on the RCCanada - Canada Radio Controlled Hobby Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionally, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Your Name
Your first name and last initial is required if you plan on using the forum.
Which city & province you live in. This is mandatory for classified listings.
Radio of choice?
Which radio is your current favorite to use?
Number of RC Vehicles?
How many boats, cars, planes do you own?


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
vBulletin Message

Thread Tools
Display Modes

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Nano Boomerang EricD FS - Airplanes 3 07-16-2012 02:16 PM
nitor 7 cxp engine greener_dude Nitro RC Car and Truck Discussion 2 09-20-2011 07:07 PM
Nano-Tech pelgar FS - Electric Gear 3 09-03-2011 01:27 PM
Boomerang Nano Rcpete FS - Airplanes 1 04-15-2011 09:12 PM
Nano-Nano KAPTAN KAOS Jet Aircraft 7 11-02-2009 09:05 PM

All times are GMT -5. The time now is 08:33 AM.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.