strange possible servo glitch? hoping for some help - RCCanada - Canada Radio Controlled Hobby Forum
RCCanada - Canada's Radio Control Hobby Forum
Nitro RC Car and Truck Discussion Discuss nitro RC vehicles

Thread Tools Display Modes
Old 09-16-2014, 09:03 AM   #1
RCC Noob
I am: nick v.
Join Date: Jul 2014
Location: moncton NB
Radio of choice:
stock traxxas junk
# of RCs: 1

Feedback: 0 / 0%
Posts: 1
Total Props: 0
strange possible servo glitch? hoping for some help

       Remove this ad - become a site supporter!
hey, im kind of new to this forum, been out of rc for a very long time, but just got back into it after some time off from motocross racing.

i have a very strange issue with a losi aftershock i picked up used and poorly set up. ive gone through it and it runs great now and was driving fine with a salvaged old tamiya am TxRx with a busted antenna. everything worked fine, but if i got more than 5 feet away from it, it would glitch insanely. this receiver was put in by the previous owner who said it had a problem with the JR receiver set it had been using where it would glitch out and randomly lock the steering hard to the left and stop working.

out of curiosity, i hooked up the old JR system and it did exactly as described. since then i have put a few other TxRx combos in it with strange results. some wont work at all even though they were working fine in other models, and the last one was the TxRx from my old rustler. i put everything in and it seemed to cure all my issues. took it out to do some tuning, and all of a sudden it starts doing the exact same thing again, but with a new twist to it that makes it dangerous to drive. once the steering goes full lock left, it then waits a moment, and slams the throttle wide open. luckily it did a backflip and landed in the ditch upside down.

this receiver and transmitter was working flawlessly in my rustler for the last few months. i havent put the Tamiya receiver back in yet, as the range issues are as big of a concern as these other problems.

i have a spectrum dx3 for my 1/8 scale truggy that i am trying to find a spare receiver for so i can use that in the losi, but i have a worry that there may be something else going on here. is there any way that a bad servo could possibly cause issues with the reciever and be causing the wide open throttle issue?

anyways, sorry for the long post, and thanks for any help you guys might be able to provide me with.
droopy is offline   Quick reply to this message.

Sponsored Links - Subscribe to remove this ad.

Quick Reply

Register Now

In order to be able to post messages on the RCCanada - Canada Radio Controlled Hobby Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionally, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Your Name
Your first name and last initial is required if you plan on using the forum.
Which city & province you live in. This is mandatory for classified listings.
Radio of choice?
Which radio is your current favorite to use?
Number of RC Vehicles?
How many boats, cars, planes do you own?


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
vBulletin Message

Thread Tools
Display Modes

Forum Jump

All times are GMT -5. The time now is 11:11 PM.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.