Pixhawk and Relays? - RCCanada - Canada Radio Controlled Hobby Forum
RCCanada - Canada's Radio Control Hobby Forum
Multi Rotor Discussion Tri's, Quad's, Hex'as and more. Discuss anything multi-rotor, including multi-rotor stabilization and FPV setups.

Thread Tools Display Modes
Old 01-07-2015, 11:57 PM   #1
RCC Noob
I am: Natalie
Join Date: Jan 2015
Location: BC
Radio of choice:
turnigy 9xr
# of RCs: 2

Feedback: 0 / 0%
Posts: 1
Total Props: 0
Pixhawk and Relays?

       Remove this ad - become a site supporter!
Hi. I am fairly new to this and am calling on all rc buddies to help on an issue I have run into...

Okay, so here is the low down on our issues with this unit:

I am trying to get Pixhawk to control a relay and am using channel 8 on the radio. The relay power in is connected to battery, relay power out is connected to a light, the signal cable from relay is plugged into aux out 5 on Pixhawk. This cable has black, red, and signal. The switch on the transmitter does not turn the light on. My question is does Pixhawk need only the signal wire? Have we missed some other settings? In config/tuning we have first relay pin set to Pixhawk aux 5. We have ch8 opt set to relay on/off.

1.) Official 3DR email support says "all we have is what the wiki says" which is not very helpful

2.) I now powered the servo rail with 5v bec.... ta da!! I can get the relay to turn on but it will NOT turn off. Looks like a one shot deal. Turn on once, stay on until you pull the plug

It seems pretty silly to me - why call it aux out? - Why call it a relay? If there is no other info available other than a wiki that just says "this is a relay pin"?

Its a bit disappointing. Pixhawk was supposed to be the cats ass and a bit more sophisticated than this isn't it?

Channel 8 on the radio is scrolling between 900 and 2000 for on off. In the off position (900), the relay is off. Turn on and the radio goes to 2000 and turns on the relay. Flick the switch back to off (900) and the relay stays on...makes no sense at all.

Does anyone out there know what I need to do to get the relay to work properly?
Gnaw is offline   Quick reply to this message.

Sponsored Links - Subscribe to remove this ad.

Quick Reply

Register Now

In order to be able to post messages on the RCCanada - Canada Radio Controlled Hobby Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionally, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Your Name
Your first name and last initial is required if you plan on using the forum.
Which city & province you live in. This is mandatory for classified listings.
Radio of choice?
Which radio is your current favorite to use?
Number of RC Vehicles?
How many boats, cars, planes do you own?


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
vBulletin Message

Thread Tools
Display Modes

Forum Jump

All times are GMT -5. The time now is 03:19 AM.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.