Pixhawk Radio Control Won't Recognize, Please Help!!! - RCCanada - Canada Radio Controlled Hobby Forum
RCCanada - Canada's Radio Control Hobby Forum
Multi Rotor Discussion Tri's, Quad's, Hex'as and more. Discuss anything multi-rotor, including multi-rotor stabilization and FPV setups.

Thread Tools Display Modes
Old 04-30-2015, 08:48 AM   #1
Craig P.
RCC Noob
I am: Craig
Join Date: Mar 2015
Location: Toronto, Ontario
Radio of choice:
Turnigy 9XR
# of RCs: 4

Feedback: 0 / 0%
Posts: 6
Total Props: 0
Pixhawk Radio Control Won't Recognize, Please Help!!!

       Remove this ad - become a site supporter!
Hello folks,

As I've yet to get much a response on previous post regarding a pixhawk which has the error code "Radio control not active", however it is most certainly active. as I can connect a motor to the 3 pin slot on my X8R and can spin the motor effectively with the throttle.

Not to sound negative, but I'm really at my wits end with this pixhawk and its trouble some lack of response for an rc signal. I have this particular pixhawk in my X8 I require for mapping in the near future and it simply refuses to recognize an rc signal. I have tested my frsky ppm encoder with no avail n'or will my 3dr ppm encoder. It did work previous to this with both the frsky sbus-ppm encoder as well as the 3dr ppm encoder.
I travelled with the auto pilot and upon attempting flight back in December after flashing the latest firmware at the time, it then would no longer recognize a signal? Its kinda disappointing considering my other pixhawks have worked perfectly out of box with the same exact setup without the need for any encoders but simply direct from sbus.
I would hate to have it just sit on a shelf after the amount that Ive invested into getting it to work (ppm encoders, plus cost of all electronics such as gps ect...) and it hasn't ever worked properly.

If any one would have advice on how to maybe test what may be occurring that would cause the pixhawk not to pick up a signal would be very very much appreciated, or perhaps anyone who may know how to trouble shoot the autopilot themselves (maybe an individuals in the toronto area?), as I require this particular drone in order to complete my research and would not want to spend to much more.

Thanks in advance for any advice, suggestions or feedback it is very appreciated!

Craig P.
Craig P. is offline   Quick reply to this message.

Sponsored Links - Subscribe to remove this ad.
Old 04-30-2015, 12:46 PM   #2
RCC Expert Contributor
I am: R D
Join Date: Jan 2009
Location: Kincardine

Feedback: 1 / 100%
Posts: 903
Total Props: 39
Re: Pixhawk Radio Control Won't Recognize, Please Help!!!

So what exactly are you using to connect?

I'm assuming it is an X8R as that is the only receiver you have mentioned owning? have you verified that it is actually outputting anything to the PPM encoder?

Have you tried connecting via S.bus rather than using the PPM encoder?

What are you seeing in the radio calibration portion of Mission Planner?
Helno is offline   Quick reply to this message.
Old 04-30-2015, 03:23 PM   #3
Craig P.
RCC Noob
I am: Craig
Join Date: Mar 2015
Location: Toronto, Ontario
Radio of choice:
Turnigy 9XR
# of RCs: 4

Feedback: 0 / 0%
Posts: 6
Total Props: 0
Re: Pixhawk Radio Control Won't Recognize, Please Help!!!

Hi @Helno,

sorry for not clarifying, you are right I am in fact using a X8R with a XJT into a turnigy 9XR.

I did connect a ESC+motor to the 3pin on the X8r and throttle does indeed control the motor on that aspect, so it would seem the pixhawk is not reading the signal? I have another pixhawk and the setup does in fact work, just for some reason this particular pixhawk has never worked properly...
I have tried without ppm encoders (my other pixhawk in ran that way and works perfectly), and in my APM Planner i get nothing, in fact when I try to run radio calibration it simply says radio control not active? Thats why I figured it may be a hardware issue within the pixhawk but it did work temporarily with a encoder last summer + fall, until i ran the december firmware update?
I'm pretty sure its one from the first production batch of pixhawks but I could be wrong...

Thanks for your response, hopefully I can get this resolved.

Craig P. is offline   Quick reply to this message.

Quick Reply

Register Now

In order to be able to post messages on the RCCanada - Canada Radio Controlled Hobby Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionally, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Your Name
Your first name and last initial is required if you plan on using the forum.
Which city & province you live in. This is mandatory for classified listings.
Radio of choice?
Which radio is your current favorite to use?
Number of RC Vehicles?
How many boats, cars, planes do you own?


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
vBulletin Message

Thread Tools
Display Modes

Forum Jump

All times are GMT -5. The time now is 03:07 AM.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.