Hitec 2.4gig.... when did this happen - Page 5 - RCCanada - Canada Radio Controlled Hobby Forum
RCCanada - Canada's Radio Control Hobby Forum
General RC Aircraft Discussion Discuss anything RC related

Closed Thread
Thread Tools Display Modes
Old 02-19-2009, 05:31 PM   #41
Ken Currell
I am: Ken Currell
Join Date: Jun 2004
Location: Whitby, Ontario
Radio of choice:
Multiplex Royal Evo
# of RCs: 30+

Feedback: 3 / 100%
Posts: 3,688
Total Props: 0
Re: Hitec 2.4gig.... when did this happen

       Remove this ad - become a site supporter!
I'm happy to wait for the Multiplex module.
Since it seems that it won't be compatible with the MPX I quess I won't be buying one.

All of the current radios are far better than the stuff we had a few years ago. The more complicated the electronics, the more chance there is of a problem, but those seew to be few and far between.

I think the quality of the assembly process may be suspect as the cause of some failures.

I have Royal Evo and 30 30 transmitters that can be retro-fitted with the proper modules.

I'm still keeping my 72 MHZ stuff.
Ken Currell is offline   Quick reply to this message.

Sponsored Links - Subscribe to remove this ad.
Old 02-20-2009, 12:15 PM   #42
Join Date: Oct 2005
Location: Edmonton, Alberta

Feedback: 0 / 0%
Posts: 22
Total Props: 0
Re: Hitec 2.4gig.... when did this happen

Hi Mikej,

What was happening was we would center all the servos as best we could with the subtrims and then start programming the curves. Then we would start trying to use a pitch gauge and were finding that after a few minutes, our swashplate wasn't level. It took a while but we found we could recreate it at will by putting the collective stick at the extreme top or bottom. It was like something was shorting out or something like that but the effect was that it would reset all subtrims to zero.

This happened about three to four years ago and may not even be an issue today. It just set me up to avoid this brand. We saw it on more than one radio and one pilot sent his radio back and it sill didn't fix it (at the time) He ended up dumping it and going Futaba.

eSmith is offline   Quick reply to this message.
Closed Thread

Quick Reply

Register Now

In order to be able to post messages on the RCCanada - Canada Radio Controlled Hobby Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionally, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Your Name
Your first name and last initial is required if you plan on using the forum.
Which city & province you live in. This is mandatory for classified listings.
Radio of choice?
Which radio is your current favorite to use?
Number of RC Vehicles?
How many boats, cars, planes do you own?


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
vBulletin Message

Thread Tools
Display Modes

Forum Jump

All times are GMT -5. The time now is 05:55 AM.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.